WarpBuild - Remote docker builders and arm64 runners are not functional because of the AWS outage – Incident details

Remote docker builders and arm64 runners are not functional because of the AWS outage

Resolved
Major outage
Started 4 days agoLasted about 13 hours

Affected

GitHub Runners

Partial outage from 9:00 AM to 9:54 PM, Operational from 9:54 PM to 10:00 PM

Docker Builders

Major outage from 9:00 AM to 9:54 PM, Operational from 9:54 PM to 10:00 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We are seeing full recovery in the impacted services:

    • Docker builders

    • arm64 runners

    • custom runners

    • Snapshot runners

    • Windows runners

    x64 runners were not impacted and are continuing to work as usual.

  • Update
    Update

    Windows runners are also impacted because of the AWS outage.

  • Identified
    Identified

    Remote docker builders and arm64 runners are not functional because of the AWS outage

    There may be some delay in jobs getting picked up because of queueing and image related delays.

    Windows, custom runners, and snapshot runners are also affected.