WarpBuild - WarpBuild Runners are not starting with a "failed to fetch" error – Incident details

WarpBuild Runners are not starting with a "failed to fetch" error

Resolved
Major outage
Started 6 days agoLasted 7 minutes

Affected

GitHub Runners

Major outage from 7:16 AM to 7:23 AM

Updates
  • Postmortem
    Postmortem

    The issue was caused because of a faulty change to the auth service during a refactor. This was not expected to have an impact on the runner allocation flow. This was reverted to fix the error. We are also going to add tests to ensure issues of this nature do not creep through.

  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.